// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\w\d\._%+-]+@[\w\d.-]+\.[\w]{2,4}").unwrap();
let string = "zzzz@mygmail.com
coolio.jones@mygmail.com
myinvalid&crazy*email@ziggybot.co.uk
http://memberpress.com
Meet me @ 5:00 in the Lobby
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}