re = /[\w\d\._%+-]+@[\w\d.-]+\.[\w]{2,4}/
str = 'zzzz@mygmail.com
coolio.jones@mygmail.com
myinvalid&crazy*email@ziggybot.co.uk
http://memberpress.com
Meet me @ 5:00 in the Lobby
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end