package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\[[^\]]+`)
var str = `aaaaaaaaa[aaaaa]aaaa[bbbbbbb]aaaa`
var substitution = "[x"
fmt.Println(re.ReplaceAllString(str, substitution))
}