import re
regex = re.compile(r"\[[^\]]+", flags=re.MULTILINE | re.IGNORECASE)
test_str = "aaaaaaaaa[aaaaa]aaaa[bbbbbbb]aaaa"
subst = "[x"
result = regex.sub(subst, test_str)
if result:
print(result)