import Foundation
let pattern = #"\[[^\]]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"aaaaaaaaa[aaaaa]aaaa[bbbbbbb]aaaa"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[x"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)