// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\[[^\]]+").unwrap();
let string = "aaaaaaaaa[aaaaa]aaaa[bbbbbbb]aaaa";
let substitution = "[x";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}