use strict;
my $str = 'aaaaaaaaa[aaaaa]aaaa[bbbbbbb]aaaa';
my $regex = qr/\[[^\]]+/mip;
my $subst = '[x';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";