$re = '/\[[^\]]+/mi';
$str = 'aaaaaaaaa[aaaaa]aaaa[bbbbbbb]aaaa';
$subst = "[x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;