#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?:^|\s)[a-z])(?!nd\b|r\b)"
Local $sString = "alexis Sanchez" & @CRLF & _
"sanchez's or ball" & @CRLF & _
"sanchez and co"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)