re = /((?:^|\s)[a-z])(?!nd\b|r\b)/
str = 'alexis Sanchez
sanchez\'s or ball
sanchez and co'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result