$re = '/((?:^|\s)[a-z])(?!nd\b|r\b)/';
$str = 'alexis Sanchez
sanchez\'s or ball
sanchez and co';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;