using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:^|\s)[a-z])(?!nd\b|r\b)";
string substitution = @"$1";
string input = @"alexis Sanchez
sanchez's or ball
sanchez and co";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}