#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b((?:[23456789]|[123456789]\d+)[05])\b"
Local $sString = "05" & @CRLF & _
"005" & @CRLF & _
"10" & @CRLF & _
"15" & @CRLF & _
"20" & @CRLF & _
"21" & @CRLF & _
"25" & @CRLF & _
"105" & @CRLF & _
"101" & @CRLF & _
"13"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")