$re = '/\b((?:[23456789]|[123456789]\d+)[05])\b/';
$str = '05
005
10
15
20
21
25
105
101
13';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);