import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:[23456789]|[123456789]\\d+)[05])\\b";
final String string = "05\n"
+ "005\n"
+ "10\n"
+ "15\n"
+ "20\n"
+ "21\n"
+ "25\n"
+ "105\n"
+ "101\n"
+ "13";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}