import Foundation
let pattern = #"\b((?:[23456789]|[123456789]\d+)[05])\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
05
005
10
15
20
21
25
105
101
13
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}