const regex = /\b((?:[23456789]|[123456789]\d+)[05])\b/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?:[23456789]|[123456789]\\d+)[05])\\b', '')
const str = `05
005
10
15
20
21
25
105
101
13`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}