import re
regex = re.compile(r"\b((?:[23456789]|[123456789]\d+)[05])\b")
test_str = ("05\n"
"005\n"
"10\n"
"15\n"
"20\n"
"21\n"
"25\n"
"105\n"
"101\n"
"13")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")