#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*(?:\d+:|[A-Z]+)\s*"
Local $sString = "147 EUR | 39927: 86.9 EUR | 39928: 49.35 EUR"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)