re = /\s*(?:\d+:|[A-Z]+)\s*/m
str = '147 EUR | 39927: 86.9 EUR | 39928: 49.35 EUR'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result