$re = '/\s*(?:\d+:|[A-Z]+)\s*/m';
$str = '147 EUR | 39927: 86.9 EUR | 39928: 49.35 EUR';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;