import re
regex = re.compile(r"\s*(?:\d+:|[A-Z]+)\s*", flags=re.MULTILINE)
test_str = "147 EUR | 39927: 86.9 EUR | 39928: 49.35 EUR"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)