const regex = /\s*(?:\d+:|[A-Z]+)\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(?:\\d+:|[A-Z]+)\\s*', 'gm')
const str = `147 EUR | 39927: 86.9 EUR | 39928: 49.35 EUR`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);