using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?:\d+:|[A-Z]+)\s*";
string substitution = @"";
string input = @"147 EUR | 39927: 86.9 EUR | 39928: 49.35 EUR";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}