import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@[^\\{]+\\{(?>[^\\{\\}]+ | (?R))+?\\}";
final String string = "@font-face\n"
+ " {\n"
+ " font-family: Gloria script;\n"
+ " \n"
+ "}\n\n"
+ ".header li {\n"
+ " width: auto;\n"
+ "}\n\n"
+ "@media( max-width: 470px ) {\n"
+ " .clbar {\n"
+ " position: static;\n"
+ " right: auto;\n"
+ " top: auto;\n\n"
+ " }\n"
+ " .clent {\n"
+ " margin: 30px 0 10px;\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}