import re
regex = re.compile(r"""
@[^{]+{(?>[^{}]+ | (?R))+?}
""", flags=re.DOTALL | re.VERBOSE)
test_str = ("@font-face\n"
" {\n"
" font-family: Gloria script;\n"
" \n"
"}\n\n"
".header li {\n"
" width: auto;\n"
"}\n\n"
"@media( max-width: 470px ) {\n"
" .clbar {\n"
" position: static;\n"
" right: auto;\n"
" top: auto;\n\n"
" }\n"
" .clent {\n"
" margin: 30px 0 10px;\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")