re = /@[^{]+{(?>[^{}]+ | (?R))+?}/x
str = '@font-face
{
font-family: Gloria script;
}
.header li {
width: auto;
}
@media( max-width: 470px ) {
.clbar {
position: static;
right: auto;
top: auto;
}
.clent {
margin: 30px 0 10px;
}
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end