import Foundation
let pattern = #"@[^{]+{(?>[^{}]+ | (?R))+?}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
@font-face
{
font-family: Gloria script;
}
.header li {
width: auto;
}
@media( max-width: 470px ) {
.clbar {
position: static;
right: auto;
top: auto;
}
.clent {
margin: 30px 0 10px;
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)