import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\s\\S].*?)(?<=area\\/)([^-])([^-]*)(-)([^\\/])([^\\/]*).*";
final String string = "abc/123/area/my-folder/state/...";
final String subst = "/\\U$1\\E$2$3\\U$4\\E$5/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}