use strict;
my $str = 'abc/123/area/my-folder/state/...';
my $regex = qr/(?:[\s\S].*?)(?<=area\/)([^-])([^-]*)(-)([^\/])([^\/]*).*/mp;
my $subst = '/\\U$1\\E$2$3\\U$4\\E$5/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";