$re = '/(?:[\s\S].*?)(?<=area\/)([^-])([^-]*)(-)([^\/])([^\/]*).*/m';
$str = 'abc/123/area/my-folder/state/...';
$subst = "/\U$1\E$2$3\U$4\E$5/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;