import Foundation
let pattern = #"(?:[\s\S].*?)(?<=area\/)([^-])([^-]*)(-)([^\/])([^\/]*).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"abc/123/area/my-folder/state/..."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"/\U$1\E$2$3\U$4\E$5/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)