const regex = /(?:[\s\S].*?)(?<=area\/)([^-])([^-]*)(-)([^\/])([^\/]*).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[\\s\\S].*?)(?<=area\\\/)([^-])([^-]*)(-)([^\\\/])([^\\\/]*).*', 'gm')
const str = `abc/123/area/my-folder/state/...`;
const subst = `/\U$1\E$2$3\U$4\E$5/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);