# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a href="([^"
]*)">([^<]*)<.*/[$2]($1)/;t' <<< "<a href=\"http://coffee.stackexchange.com/users/179/mooz\">Mooz</a>"