import re
regex = re.compile((r"<a href=\"([^\"\n"
r"]*)\">([^<]*)<.*"))
test_str = "<a href=\"http://coffee.stackexchange.com/users/179/mooz\">Mooz</a>"
subst = "[$2]($1)"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)