re = /<a href="([^"
]*)">([^<]*)<.*/
str = '<a href="http://coffee.stackexchange.com/users/179/mooz">Mooz</a>'
subst = '[$2]($1)'
result = str.sub(re, subst)
# Print the result of the substitution
puts result