use strict;
my $str = '<a href="http://coffee.stackexchange.com/users/179/mooz">Mooz</a>';
my $regex = qr/<a href="([^"
]*)">([^<]*)<.*/p;
my $subst = '[$2]($1)';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";