#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\\);((?:\[[^\]]*\]|\\;|[^;])+)$"
Local $sString = "lazy;dog;are;running" & @CRLF & _
"[^;]*;dog;are;[^;]*" & @CRLF & _
"[^,;:0-9]*;dog;are;\;running"
Local $sSubst = ";[^;]*;\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)