re = /(?<!\\);((?:\[[^\]]*\]|\\;|[^;])+)$/m
str = 'lazy;dog;are;running
[^;]*;dog;are;[^;]*
[^,;:0-9]*;dog;are;\\;running'
subst = ';[^;]*;\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result