use strict;
my $str = 'lazy;dog;are;running
[^;]*;dog;are;[^;]*
[^,;:0-9]*;dog;are;\\;running';
my $regex = qr/(?<!\\);((?:\[[^\]]*\]|\\;|[^;])+)$/mp;
my $subst = ';[^;]*;\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";