$re = '/(?<!\\\\);((?:\[[^\]]*\]|\\\\;|[^;])+)$/m';
$str = 'lazy;dog;are;running
[^;]*;dog;are;[^;]*
[^,;:0-9]*;dog;are;\\;running';
$subst = ";[^;]*;\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;