using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\\);((?:\[[^\]]*\]|\\;|[^;])+)$";
string substitution = @";[^;]*;\1";
string input = @"lazy;dog;are;running
[^;]*;dog;are;[^;]*
[^,;:0-9]*;dog;are;\;running";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}