using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([^():\r\n]*:[^()]+(\((?:[^()]|(?2))*\))\))";
string input = @"website/archive(/2015(/:month(:day)))
website/archive(/:year(/:month(27)))
website/archive(/:year(/03(27)))
(string)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}