$re = '/\(([^():\r\n]*:[^()]+(\((?:[^()]|(?2))*\))\))/m';
$str = 'website/archive(/2015(/:month(:day)))
website/archive(/:year(/:month(27)))
website/archive(/:year(/03(27)))
(string)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);