re = /\(([^():\r\n]*:[^()]+(\((?:[^()]|(?2))*\))\))/m
str = 'website/archive(/2015(/:month(:day)))
website/archive(/:year(/:month(27)))
website/archive(/:year(/03(27)))
(string)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end