package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(([^():\r\n]*:[^()]+(\((?:[^()]|(?2))*\))\))`)
var str = `website/archive(/2015(/:month(:day)))
website/archive(/:year(/:month(27)))
website/archive(/:year(/03(27)))
(string)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}