import re
regex = re.compile(r"\(([^():\r\n]*:[^()]+(\((?:[^()]|(?2))*\))\))", flags=re.MULTILINE)
test_str = ("website/archive(/2015(/:month(:day)))\n"
"website/archive(/:year(/:month(27)))\n"
"website/archive(/:year(/03(27)))\n"
"(string)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")