import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(([^():\\r\\n]*:[^()]+(\\((?:[^()]|(?2))*\\))\\))";
final String string = "website/archive(/2015(/:month(:day)))\n"
+ "website/archive(/:year(/:month(27)))\n"
+ "website/archive(/:year(/03(27)))\n"
+ "(string)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}