use strict;
my $str = '\'SYS W$_FIasdfLESTATXS TABLE PARTITION 0 \'';
my $regex = qr/(?<! ) (?! )/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";