import Foundation
let pattern = #"(?<! ) (?! )"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"'SYS W$_FIasdfLESTATXS TABLE PARTITION 0 '"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)